Please consider registering
sp_LogInOut Log In
Register | Lost password?
Advanced Search
Forum Scope


Forum Options

Minimum search word length is 3 characters – maximum search word length is 84 characters
sp_Feed Topic RSSspace
Diamonds 2 fully loaded games will not launch
November 1, 2020
4:46 pm

Forum Posts: 5
Member Since:
November 30, 2019
sp_UserOfflineSmall Offline

Ok, downloaded Diamonds 2 PC fully loaded , when I pick a game the title flies out and the screen goes black, then right back to the frontend.
Seems to happen with any coin ops I try to run, I tried the Coin Ops Diamond first one also does this.
Not seeing any fixes for this, help?

November 2, 2020
9:43 am
Ninja UK
Forum Posts: 2618
Member Since:
May 14, 2015
sp_UserOfflineSmall Offline

Im suspecting virus killer picking up something as a false positive , wondering if its deleted a file… Can I suggest disable AV, re-extract Diamonds 2 and try it then , keep the anti virus off

November 2, 2020
7:37 pm

also downloaded this on both varients nzb/torrent ,gone to extract both version report win32:mdeclass malware via avg , launcher sent to quarantine

November 3, 2020
4:03 pm

First step, make sure to install DirectX 9c which is already included in the folder “Fixes when not working!!!”

Second, I ran into the same issue and what you need to do is go into the Mame.ini file and find the # OSD VIDEO OPTIONS. Change the video to opengl

Try launching again and it should work! If you’re having issues with the MAME launching on the wrong monitor if you have a multi display setup,
you can try going into the # OSD PER-WINDOW VIDEO OPTIONS and find all entries where it says “screen” and then put in the command \\.\DISPLAY#.

# = the screen number you have starting at 0 as monitor 1. Here is an example:

screen \\.\DISPLAY2
aspect auto
resolution auto
view auto

Hope this works.

November 3, 2020
6:41 pm
Forum Posts: 25
Member Since:
January 22, 2020
sp_UserOfflineSmall Offline

One question and one suggestion.

Are you running the 64 bit Windows? CoinOPS Diamonds runs MAME64, which would give you a similar result to what you have on a 32 bit system. The fix is pretty easy.

Otherwise, run CoinOPS Diamonds and (try to) run one arcade game, then exit CoinOPS. A text file called “log.txt” is created in the root folder detailing everything CoinOPS does from start up to exiting. The last few lines of the file will show the game you tried to run, and the results of that attempt. This might give you a clue as to what is going on.

I downloaded CoinOPS Diamonds from the torrent here at Arcade Punks and Windows Defender reports it as being clean, and it runs fine. Since it runs just RetroFE and MAME, there shouldn’t be anything that would flag any anti virus app.

It looks like the RetroFE side is running okay for you, but MAME fails. Try running “MAME64.exe” in the coinOPS “emulators” by itself. Just double click it, MAME has a built-in interface.

November 3, 2020
9:20 pm

Forum Posts: 7
Member Since:
May 17, 2018
sp_UserOfflineSmall Offline

Technopope said
One question and one suggestion.

Are you running the 64 bit Windows? CoinOPS Diamonds runs MAME64, which would give you a similar result to what you have on a 32 bit system. The fix is pretty easy.  

Can we simply remove mame64 and replace with 32bit version of mame ?

New to coinops and every version I try from here does the black screen and back to menu trick, are they all for 64bit ?

November 3, 2020
10:53 pm
Forum Posts: 25
Member Since:
January 22, 2020
sp_UserOfflineSmall Offline

Check what your Windows version is by selecting “System” and “About” in the Windows Settings, your Windows system type will show up under “Device specifications”. I assume you are running Windows 10.

Every fairly recent Windows computer is 64 bit (Microsoft stopped selling Windows 32 in May), but if you are using an older computer for a retro gaming system or cabinet, there is a chance it is 32 bits. Not to worry, though, as CoinOPS Diamonds includes both the 32 and 64 bit versions of MAME. The 32 bit one is called “MAME.exe” and “MAME64.exe” is 64 bits. Try running “MAME.exe” directly by just double clicking, it has a build in interface. If it runs, your fix is this:

Edit the file “mame.conf” located in the “launchers.windows” folder. This is a text file that tells RetroFE how to run the games. Every emulator has one of these files, which directs your game selection from CoinOPS to the proper emulation folder and program. The MAME launcher contains this:

executable = emulators\MAME\mame64.exe
arguments = “%ITEM_NAME%”

This points to the 64 bit version of MAME. To change this to the 32 bit version (if running “MAME.exe” by itself works for you) to this:

executable = emulators\MAME\mame.exe
arguments = “%ITEM_NAME%”

Note that the only change is the removal of “64”. It is always a good idea to make a copy of the original file before you make any changes. Use the Windows Notepad program to edit. (Or download “Notepad++”, a *much* better editor, and FREE!) Be warned that doing this alteration will change the Official CoinOPS setup and future add-ons might not work.

Remember this will only work if your system is 32 bits and you are able to run “MAME.exe” by itself. If your system is Windows 64 bits, I have no idea otherwise why it isn’t working. (You DID install Direct X 9 from the folder called “- Fixes when not working!!!” Right?)

Forum Timezone: Europe/London
Most Users Ever Online: 3117
Currently Online: kabutokoji, djvoodoo, spurgo, simon simon, Neirivaldo
Guest(s) 39
Currently Browsing this Page:
1 Guest(s)
Top Posters:
canter6: 131
Jaz808: 121
test123: 84
davep180: 81
SteelCityJJ: 76
MyRetrozz: 70
Misa Misa: 70
kme2019: 61
-x-: 53
sergiohyperspin: 52
Member Stats:
Guest Posters: 122
Members: 165064
Moderators: 32
Admins: 1
Forum Stats:
Groups: 7
Forums: 37
Topics: 4477
Posts: 12989
Newest Members:
dmstills, NegritoUsuriaga, cl4w, Reynier, [email protected], Alexisz06, jfrankut, superneo77, holyvipr, Neirivaldo
Moderators: aladdin: 0, Arcade Man: 0, Arcade Punk: 0, CP78: 0, ETA PRIME: 0, Ghost Lost: 0, Harrison Hacks: 0, T.K.O. Cinematics: 0, kiodiekin1: 0, level1online: 0, hursty1: 0, Neighbourhood Techie: 0, Maria: 0, PatmanQC: 0, Restalgia: 0, RetroHumanoid: 0, Simply Austin: 0, titipilas: 0, Titi Ober: 179, Enkak: 46, leepspvideo: 0, _RetroTech100: 0, Guest Post: 0, Mark Blackwood: 0, Frankie Wilde: 0, Jeremy Reynolds: 0, Leslie Alexander: 0, Jason Copley: 0, Eleonora: 0, Joshua Robinson: 0, James Collins: 0, trevor punt: 39
Administrators: Ninja UK: 2618