Please consider registering
sp_LogInOut Log In
Register | Lost password?
Advanced Search
Forum Scope


Forum Options

Minimum search word length is 3 characters – maximum search word length is 84 characters
sp_Feed Topic RSS02-yellowpac
New to Images…unable to boot SD Card
January 9, 2021
5:07 pm

I have tried 3 different loaded images for RPI4, and all get the same error screen when booting. I am not sure if its an issue with the images or something on my end. My other card running Raspian with Retropie loaded on top works fine. I am new to this so any help would be appreciated.

NZB image (tried Damasco 64GB and Wolfanoz 64GB, 128GB)
RPI4B 8GB, overclocked to 2000, with Ice Tower fan
Canakit 3.5A RPI4 power supply
128GB SanDisk Ultra 128GB SD Card
Etcher imager

When i boot up i get a black screen with a lot of text. not sure if i can post an image of it? it says SD card detected then text about “recover4.elf and recovery.elf not found. This board requires newer software. Error 00000044. Insert SD-CARD”

The images say they are RPI4…am I doing something wrong?

Any help appreciated

Forum Timezone: Europe/London
Most Users Ever Online: 3117
Currently Online: tex1968, MW95WTBGITI
Guest(s) 41
Currently Browsing this Page:
1 Guest(s)
Top Posters:
canter6: 131
Jaz808: 121
test123: 84
davep180: 81
SteelCityJJ: 76
MyRetrozz: 70
Misa Misa: 70
kme2019: 61
-x-: 53
sergiohyperspin: 52
Member Stats:
Guest Posters: 122
Members: 164960
Moderators: 32
Admins: 1
Forum Stats:
Groups: 7
Forums: 36
Topics: 4426
Posts: 12906
Newest Members:
jim050315, germy81, xGAMESx, Deli Inacio, macande206, currupio, Benicase, leodj, Moev, electro20015
Moderators: aladdin: 0, Arcade Man: 0, Arcade Punk: 0, CP78: 0, ETA PRIME: 0, Ghost Lost: 0, Harrison Hacks: 0, T.K.O. Cinematics: 0, kiodiekin1: 0, level1online: 0, hursty1: 0, Neighbourhood Techie: 0, Maria: 0, PatmanQC: 0, Restalgia: 0, RetroHumanoid: 0, Simply Austin: 0, titipilas: 0, Titi Ober: 179, Enkak: 46, leepspvideo: 0, _RetroTech100: 0, Guest Post: 0, Mark Blackwood: 0, Frankie Wilde: 0, Jeremy Reynolds: 0, Leslie Alexander: 0, Jason Copley: 0, Eleonora: 0, Joshua Robinson: 0, James Collins: 0, trevor punt: 39
Administrators: Ninja UK: 2556