Please consider registering
sp_LogInOut Log In
Register | Lost password?
Advanced Search
Forum Scope


Forum Options

Minimum search word length is 3 characters – maximum search word length is 84 characters
sp_Feed Topic RSS02-yellowpac
PiPiggies 128Gb Fully Loaded Attract Mode Problem..
October 26, 2017
11:50 pm

Forum Posts: 2
Member Since:
June 11, 2017
sp_UserOfflineSmall Offline

Hi all, This probably isnt related directly to the image im using and bear in mind Im a noob to the Pi and RetroPie. I have waited anxiously to get this image running so would appreciate any help with my problem. I first bought a chinese 128gb card that failed miserably when trying to full format, and write image in full. I then, not learning my lesson bought another cheap card from UK and have not tried a full format yet, but as it takes 3 and half hours to write an image, I just tried to write the image after a quick format.

Twice now I have successfully written the image to the card (8 hours later) and I have had same problem happen which I will explain, and Im sure someone here will be able to identify whats  going on.

When I first boot the image it comes up with an error along the lines of:

ExT4-fs error : ext4_iget:4202 : inode #516169 : comm fbi : bad extra_isize

then it hangs for about 15 minutes (busy light going) then has a few more lines come up, before a huge line of square blanks appear filling pages (so I cannot see what the command it was executing) that ends 'file name too long' and leaving me at the console with a retropie info dash containing a little environmental info like cpu temp etc.

Im hoping your not going to tell me the card is crap and is the cause of the file system corrupting. I have read that some MicroSD cards are not capable of holding the full image but when writing the image the bytes are less than what my windows machine reports are available on my card, is the accurate enough?

Im using a pi 3 model b, and win32 disk imager

any insight would be gratefully received

October 27, 2017
12:31 am

Forum Posts: 2
Member Since:
April 7, 2017
sp_UserOfflineSmall Offline

hey buddy no worries we were all new to this at 1 time or another.

its super simple once you know the right way.

1st it would probably be the best to get a samsung 128GB card as these have a little more wiggle room on them.



download and use a free program called mini tool (Â https://www.partitionwizard.com/ )

this will be used to re-format the card to fat 32 (any other format method will not work with these larger size cards)

once the card is reformatted to fat 32 then burn the image using win 32 disk imager.

when the write process is complete pop the card in yur pi ,configure your gamepad and yur off gamming.

hope that helps some what


take care

October 28, 2017
2:43 pm

Forum Posts: 2
Member Since:
June 11, 2017
sp_UserOfflineSmall Offline

Thanks for your reply..

Heres what happens when I try to execute emulationstation.. (recorded in slowmo so I could see what the garbage started with)


November 5, 2017
12:07 pm
Ninja UK
Forum Posts: 2624
Member Since:
May 14, 2015
sp_UserOfflineSmall Offline


8 hours to install the image to sd card ?

Thats never right, a couple of hours tops….


December 18, 2018
6:16 pm

Arcade Punk
Forum Posts: 1
Member Since:
December 18, 2018
sp_UserOfflineSmall Offline

hello, I am having the same error with a 128 GB image, ext4-fs error at first time boot, have any body provide an idea about what makes this to hapen??


Forum Timezone: Europe/London
Most Users Ever Online: 3117
Currently Online: test123
Guest(s) 56
Currently Browsing this Page:
1 Guest(s)
Top Posters:
canter6: 131
Jaz808: 121
test123: 89
davep180: 81
SteelCityJJ: 76
MyRetrozz: 70
Misa Misa: 70
kme2019: 61
-x-: 53
sergiohyperspin: 52
Member Stats:
Guest Posters: 122
Members: 165158
Moderators: 32
Admins: 1
Forum Stats:
Groups: 7
Forums: 37
Topics: 4489
Posts: 13010
Newest Members:
sidenir jose candido, fatnfix, gioffry76, Levis501, alanluisc, zambada, nancyhelton, Gabriel Tigu, TojiFushiguro1, Trampo_PR
Moderators: aladdin: 0, Arcade Man: 0, Arcade Punk: 0, CP78: 0, ETA PRIME: 0, Ghost Lost: 0, Harrison Hacks: 0, T.K.O. Cinematics: 0, kiodiekin1: 0, level1online: 0, hursty1: 0, Neighbourhood Techie: 0, Maria: 0, PatmanQC: 0, Restalgia: 0, RetroHumanoid: 0, Simply Austin: 0, titipilas: 0, Titi Ober: 179, Enkak: 46, leepspvideo: 0, _RetroTech100: 0, Guest Post: 0, Mark Blackwood: 0, Frankie Wilde: 0, Jeremy Reynolds: 0, Leslie Alexander: 0, Jason Copley: 0, Eleonora: 0, Joshua Robinson: 0, James Collins: 0, trevor punt: 39
Administrators: Ninja UK: 2624