You need to log in to create posts and topics.

ES-Systems.cfg File

Im having some issues with this file and would appreciate some input if possible.

I have used the command sudo chmod 0777 -R /etc/emulationstation

I have then, using WINSCP, gone into the etc/emulationstation and copied the file to my desktop. I have then renamed the file on the pi to es-systemsbackup.cfg.

Without touching the original .cfg I copy it back across to the pi using WINSCP, it copies across without errors. I then reboot the pi to be greeted with the white box that says ...

It Looks Like Your Systems Configuration File Has Not Been Setup Or Is Invalid. You`ll Need To Do This By Hand Unfortunately"

 

Any help muchly appreciated.

Looking at someone elses build I noticed the file had been named es-systems.cfg.orig

I went back to my blank build and tried the same but got the same result :(

Can I ask two questions for clarification?

1) What is it you're trying to accomplish with the command?
2) Where are you entering the command? I mean, what block of commands are you adding it to?

https://www.raspberrypi.org/forums/viewtopic.php?t=40130

Awesome Arcade Punk Member

1) I would like the option to add items to the cfg file at some point as I get a better understanding as I`m new to this.

2) I`m pressing F4 to get to the console and then using the CHMOD command giving me 0777 to the folder where the cfg file is.

 

Im at a loss as to why the error screen is coming up when all I`m doing is copying the cfg to desktop, renaming the original cfg file so I have a copy of it and then uploading the untouched file from my desktop back to the pi. Reboot and its like it cannot see the cfg ??

Thanks for any help, much appreciated.

Have you tried dropping the leading 0, CHMOD 777?

Awesome Arcade Punk Member

WinScp, drag out Config, then do what you want, back it up, edit it, what ever, then drag it back over with WinScp
Try:  sudo su then the command you want

Have not dropped the 0 but if I get the properties of the folder through WinSCP it confirms the 777 has worked.

Jaz808 that's exactly what I`m doing, as I`m a newbie could you explain what you mean about sudo su in a language an idiot could understand ;)

 

Stop all this Terminal and Sudo, its NOT they way i am going to explain:

Open WinScp, log into Pi
In WinScp along the top menu bar go to Options, then Preference, then in that first Window, make sure things like: Transfering of Files, Over Writtin of Files are ticked, have a look through as if you have any other problems it just might be a Tick in the right Option
Go to this Directory: /opt/retropie/configs/all/emulationstation
The es_systems.cfg can also be in  /etc/emulationstation  and sometimes hidden in themes:  /etc/emulationstation/themes
Now you can Drag out the es_systems.cfg to your Desktop
Important : Use Notepad++ or a good editor, DO NOT use windows Notepad, it wont keep the correct format, even WordPad can not be trusted
Once you have made your Changes, you can now drag the es_systems.cfg file back over and replace or Delete and Replace

I am betting the Format of the Config you made is corrupted, by using windows notepad ???

Jaz808 many thanks for your reply. The cfg file is untouched bud and I already use Notepad++ so if I did open it then it would be with that.

I have not looked at any settings in WinSCP but if I simply copy the cfg file to my desktop, rename the one on the pi to something like .cfg.orig then immediately copy the untouched file back to the pi and reboot I`m met with the error mentioned. This is if I do this with the cfg located in /etc/emulationstation/themes

I was then advised to leave that file alone and instead copy it to /opt/retropie/configs/all/emulationstation which I did and the pi loaded to the error again.

I then as a test chmod the /opt/retropie/configs/all/emulationstation to 777 instead of 775 and it worked when I copied the cfg file there however on reboot the cfg file changed to 0bytes and the error returned.

So I copied the cfg file to /opt/retropie/configs/all/emulationstation once again however changed the chmod back to 775 before reboot and so far the pi reboots perfect everytime.

Ive done so much I`m a but confused as to whether I have sorted it or fluked it LOL

I am still learning this stuff myself, i copy it out from: /opt/retropie/configs/all/emulationstation, make any changes like adding a new system to the bottom of the list then overwite  the original, when i copy it back to the pi, nothing more, no changing of any permissions